Tag Archives: lenny

RMagick Gem install on Debian Lenny

I run Debian Lenny and I want to install RMagick, a Ruby interface to the ImageMagick libraries. Let’s try it (i have the ruby1.9.1 packages installed on Lenny for using Ruby 1.9.2, so many “ruby” commands have a 1.9.1 appended to them):

sudo gem1.9.1 install rmagick


Can't install RMagick 2.13.1. Can't find MagickWand.h.

Also there’s some warnings about “Found more than one ImageMagick installation.” Convential wisdom and google searching suggest that we can install that handy MagickWand.h header file dependency by installing the “libmagick9-dev” package from Lenny.  Unfortunately, if you do this and then re-install the gem, you are going to get an error that looks like:

checking for ImageMagick version >= 6.4.9... no

Ouch, so to install the MagickWand.h dependency, we had to downgrade our ImageMagick install to the point where the RMagick gem won’t even try to compile. This is the problem in how the ImageMagick Lenny packages are arranged, and I don’t quite understand the logic: “libmagic-dev” provides a more recent version of ImageMagick than “libmagic9-dev”… but only the older “libmagic9-dev” has the needed header files!

What to do? Backport a newer version of ImageMagick from Squeeze, of course! Follow these instructions for adding my Debian backports repository to your apt-sources, once you’re updated (make sure to pin anything you don’t want from my backports), do this:

sudo aptitude install libmagickwand-dev
sudo gem1.9.1 rmagick

And it compiles with the latest libmagick from Squeeze:

Successfully installed rmagick-2.13.1

New Lenny Backports

After rebuilding my VirtualBox Debian Lenny development images to 64bit installations, I realized that I needed to update my Debian personal package repository to include the amd64 architecture. So! I went ahead and rebuilt the latest packages from Squeeze for amd64 and i386 for Lenny, which includes Lighttpd at 1.4.28.

The following packages from Debian Squeeze are now in the PPA:

erlang-1:14.a-dfsg-2~bpo50+1 [amd64, i386]
couchdb-0.11.0-2.1~bpo50+1 [amd64, i386]
lighttpd-1.4.28-1~bpo50+1 [amd64, i386]
dkimproxy-1.2-6~bpo50+1 [amd64, i386]

Installation instruction for aptitude

UPDATE! 2015-06-04: I no longer maintain this Debian PPA.